CCNA – Day 2

IP Subnetting- getting the number of networks and actual host in an IP range. (+2/-1, host na kapos/network na sakto)

Variable Length Subnet Mask (VLSM) – microsegmentation of a given network address to smaller segments of IP addresses.

IP Address to remember:

Private IP Address – Reserved range of IP addresses used for conserving IPv4 and IPv6 IP addresses. used for assigning IP address in a Local Area Network (LAN). These IP addresses are non-routable and cannot be used for connecting to the Internet.

IPv4 Private Address

Class A 10.0.0.0 – 10.255.255.255

Class B 172.16.0.0 – 172.31.255.255

Class C 192.168.0.0 – 192.168.255.255

 

Loopback IP address – used for testing the computer’s network interface card (NIC), operating system’s TCP/IP Implementation and self connectivity. A loopback address is “connected” to a virtual network card in your machine called the loopback adapter. Anything sent to the virtual loopback adapter comes right back out of it. It’s like it’s “connected to itself.”

127.0.0.1/8

Zero subnet

0.0.0.0/0

Network Address – serves as a unique identifier for a computer on a network. When set up correctly, computers can determine the addresses of other computers on the network and use these addresses to send messages to each other.

Broadcast Address – A special IP address used for broadcasting message and data packets in a single network system.

Automatic Private IP Addresing (APIPA) – used by microsoft to address auto configuration when there is no DHCP Server.  They are not reserved private IP address range and strictly used for APIPA only.

169.254.0.0/16  with usable range of 169.254.0.1 – 169.254.255.254

IPv4 Multicast Address – The group includes the addresses from 224.0.0.0 to 239.255.255.255. with CIDR of /4. Reserved for the use of routing protocols and other low-level topology discovery or maintenance protocols, such as gateway discovery and group membership reporting.

Cisco Internetwork Operating System (Cisco IOS) – operating system used by Cisco products such as routers, and switches.

2 Forms of Configuration File:

1. Startup-configuration – stored in Non Volatile Random Access Memory (NVRAM). Automatically booted when starting up the Cisco IOS.

2. Running-configuration – stored in Random Access Memory (RAM). Configurations that are administered while running the Cisco IOS.

DTE to DCE Connection

DTE_DCE

 

Interface

 

Interface

 

 

Configurations

Command Line Interface (CLI) Command Modes:

A>   –  User EXEC Mode – Only a limited set of show commands can be issued here and has limited privilege to issue show commands.

A#   – Priviledged EXEC Mode – All show commands are issued here.

A(config)# – Global Configuration Mode – All commands issued in this mode affects the device as a whole

A(config-if)# – Interface Configuration Mode – All commands issued in this mode affects the selected interface

Other Commands:

A>enable  –  Enables the device

A#disable – Disables the device

help/? – used when the administrator needs to know what the commands are used for. lists all the commands available for the current CLI Command mode.

 

General Router Configurations:

1. Hostname

2. Password

3. Line Console Password and Login

4. Virtual Terminal Lines (Telnet) Line VTY Login and Password

5. Idle-Timer for Console and Line VTY

6. Banner Logins

Example:

conf t
hostname R2
enable secret cisco
service password-encryption
line console 0
login
password cisco
exec-timeout 0 0
exit
line vty 0 4
login
password cisco
exec-timeout 0 0
exit
banner login $
==========================================
FOR AUTHORIZED USE ONLY. IF YOU’RE NOT AUTHORIZED DO NOT USE.. R2
==========================================
$

 

Configuring Interface IP Address:

#show ip interface brief – shows the status of the interfaces and checks if there a configured IP address

Example

R1:
conf t – enters global configuration mode
interface serial 0 – enters interface serial 0
ip address 201.52.60.2 255.255.255.0 – sets an IP address 201.52.60.2 with subnet mask of /24
no shut – turns the interface into an active state
exit – exits the interface configuration mode

R2:
conf t
interface serial 0/0
ip address 201.52.60.1 255.255.255.0
no shut
clock rate 128000 – sets a clock rate if if the device is a DCE or ISP Provider
exit

To Test Layer 3 Connectivty :

R2#ping 201.52.60.2 – pings R1 with the ip address 201.52.60.2 and checks if there’s a network connectivity

How to Telnet and Suspend Telnet Sessions:

From R2, Telnet R1:

R2#telnet 201.52.60.2

To Suspend Telnet Sessions:

Ctrl-Shift-6 + X

To Verifiy:

R2#Show Sessions

 

Routing – Path determinations and allows for communication and connection between broadcast domains and network systems.

#show ip route – displays the IP Routing Table

3 Types of Routes

1. Directly Connected Routes – Networks directly connected to a router interface are added to the router’s routing table. Interface has to have an IP address configured and both interface status codes must be in the “up and up” state. A router will be able to route all packets directly connected to its active interfaces.

2. Static Routes – Routes manually added by the administrator to the routing table.

2 Ways to Configure a Static Route
1. Exit Interface Way
Configuration Commands:
R1# conf t – enters global configuration mode
R1(config)# ip route – complete configuration syntax for configuring exit interface route
Example:
R1:
conf t
ip route 10.0.0.0 255.255.255.0 serial 0/0
exit

2. Next Hop IP Address Way
Configuration Commands:
R1# conf t – enters global configuration mode
R1(config)# ip route – complete configuration syntax for configuring next hop ip address route
Example:
R1:
conf t
ip route 10.0.0.0 255.255.255.0 201.52.60.1
exit
R1#show ip route connected – show all directly connected routes in the ip routing table
R1#show ip route static – show all manually configured static routes in the ip routing table

Static Default Routing
Default Route – A static route that is also manually configured. Route that is considered to match all destination IP addresses. There is no need to inform the router about the remote network addresses. If a router receives a packet going to a destination network that is not on the routing table, forward the packet to an exit interface/ next hop ip address.
0.0.0.0/0 – default route IP address
Configuration Commands:
R1#conf t – enters global configuration mode
R1(config)#ip route 0.0.0.0 0.0.0.0 serial 0/0 – static default routing using the router’s exit interface
R1(config)#ip route 0.0.0.0 0.0.0.0 201.52.60.1 – static default routing using the next hop IP address

A static default route can only be configured if:
1. A router is a stub router
Stub router – If a router only has 1 exit interface
2. A router that has multiple exit interfaces, is the router that is connected to the internet…Default Route_Exit Interface

R1#conf t
R1(config)#no ip routing – disables and removes all the configured IP routes
R1(config)#ip routing – enables IP routing but does not restore all the configured IP routes
R1(config)#exit – exits the global configuration mode and enters privileged EXEC mode

3. Dynamic Routes – Routes that are enabled by using dynamic routing protocols. A routing protocol is used by routers to exchange routing information with each other. Every router in a network can then use information to build its routing table. A routing protocol can dynamicaly choose a different route if a link goes down, so this type of routing is fault-tolerant. Also, unlike with static routing, there is no need to manually configure every route on every router, which greatly reduces the administrative overhead. You only need to define which routes will be advertised on a router that connect directly to the corresponding networks, routing protocols take care of the rest.
Dynamic Routing Protocols

 

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s