CCNA – Day 3

Dynamic Routing Protocols

Types of Dynamic Routing Protocols

1. Interior Gateway Routing Protocols (IGP)

  • Distance Vector Routing Protocols
    • Routing Information Protocol Version 1(RIPv1)
      • Routing Information Protocol Version 2(RIPv2)
    • Interior Gateway Routing Protocol(IGRP)
      • Enhanced Interior Gateway Routing Protocol (EIGRP)
  • Link-State Routing Protocols
    • Open Shortest Path First (OSPF)
    • Intermediate System to Intermediate System (IS-IS)

2. Exterior Gateway Routing Protocols (EGP)

  • Path Vector Routing Protocols
    • Border Gateway Protocol (BGP)

Autonomous system – group of devices within the same authority/organization. A network under the administrative control of a single organization.

Types of Routing Protocol Algorithms

  1. Distance Vector – metric = hop count or the number of routers (hops) between a router and the destination subnet. Algorithm: Bellman-Ford

RIPv1 and RIPv2 – Algorithm: Bellman-Ford

 

 

  1. Link State – metric = cost or the sum of all interface cost settings for all links in a route based on the interface bandwidth.

OSPF – Algorithm: Djikstra’s SPF

IS-IS

  1. Hybrid – metric bandwidth, delay, reliability, loading, MTU. Calculated on the route’s slowest link and the cumulative delay associated with each interface in the route.

EIGRP – Algorithrm: DUAL (Diffused Update). EIGRP has a lower convergence time as compared to OSPF.

2 Criterias for choosing the best path (Lowest value wins)

  1. Administrative Distance – When Cisco IOS chooses between different routing protocols the one with the lowest Administrative Distance wins.

Administrative Distance of Routing Protocols:

Directly Connected – 0, Statically Connected – 1, BGP – 20, EIGRP – 90, OSPF – 110, IS-IS – 115, RIP – 120, Unusable – 255

  1. Metrics – Routing protocols choose the best route by choosing route with lowest metric. Distance vector: Hop Count, Link State: Cost, Hybrid: Bandwidth, Delay, Reliability, MTU, Loading.

 

Enhanced Interior Gateway Routing Protocol (EIGRP) – Cisco proprietary routing protocol.

EIGRP Concepts and Operation

1. Neighbor Discovery: EIGRP routers send Hello messages to discover potential neighboring routers and perform basic parameter checks to determine which routers should become neighbors. Neighbors that pass all parameter checks are added to the EIGRP neighbor table.

2. Topology Exchange: Neighbors exchange full topology updated when the neighbor relationship comes up, and then only partial updates as needed based on changes to the network topology. The data learned in these updates is added to the router’s EIGRP topology table.

3. Choosing Routes: Each router analyzes its respective EIGRP topology tables, choosing the lowest-metric route to reach each subnet. EIGRP places the route with the best metric for each destination into the IPv4 routing table.

2 Things happen per network:

1. Advertise the network to a routing protocol neighbor

2. Activates the interface that is a member of the advertised network for that routing protocol (sends Hello packets = neighbor discovery)

Terms used for EIGRP

Split Horizon

Full Update – sends all advertised networks to a Routing Protocol Neighbor including all Routing Protocol learned routes.

In EIGRP and OSPF, they only send a full update once for first time neighbors. All other updates would be partial updates.

Periodic Update – Updates even if there’s no change in neighboring routers.

Partial Update – Updates only if there is a change in neighbors and the only router with the changed update will send a partial update.

Triggered Update – 2 events such as newly advertised neighbors or failed/down network

Poison reverse/route – Route with an unreachable metric, Poisoned Metric is infinity.

Keepalives

Hello Interval – 5 secs

Dead Interval – 15 secs

EIGRP Convergence:

EIGRP Convergence

Successor – Best Path/Main Path

Feasible Successor – Backup to successor in case the best path fails to prevent routing loops.

Feasible Distance(FD) – Distance from local router to the destination subnet/network

Advertised/Reported Distance (AD/RD) = The Next-hop router’s distance to the destination subnet/network

3 EIGRP Tables:

1. Neighbors

2. Topology

3. IP Routing Table

EIGRP Configuration Commands:

R1# conf t
R1(config)# router eigrp <Autonomous System number, can range from 1-65535> – sets the routing protocol to EIGRP with the selected Autonomous System number
R1(config-router)# network <directly connected network address> <wildcard mask> – advertises the network address directly connected to the router with the specified wildcard mask as identifier of the network.
R1(config-router)#no auto-summary – disables automatic network address summarization
R1(config-router)#exit – exits router configuration mode
R1(config)#exit -exits global configuration mode

Example:

R1#conf t
R1(config)# router eigrp 100
R1(config-router)#network 192.168.10.0 0.0.0.255
R1(config-router)#network 192.168.10.0 0.0.0.255
R1(config-router)#no auto-summary
R1(config-router)#exit
R1(config)#exit
R1#

Verify using:
R1#show ip route – shows IP routing table
R1#show ip protocols – shows the IP Routing protocol processes, parameters and statistics
R1#show ip eigrp neighbors – shows the EIGRP neighbor table
R1#show ip eigrp topology – show the EIGRP topology table. Shows where the feasible successors are.

Configuring Interface Bandwidths:

By default, bandwidth of all serial interface is 1544 kbps.

Example:
Set bandwidth of R1 on interface serial 0 to 2048 kbps
Configuration Commands:
R1#conf t
R1(config)#interface serial 0 – enters the interface configuration mode of serial 0
R1(config-if)#bandwidth 2048 – sets the bandwidth to 2048 kbps
R1(config-if)#end – exits to privilege EXEC mode
R1#

EIGRP Convergence

Equal Cost Load Balancing
-Load balancing if metrics are equal
-supported by RIP, EIGRP and OSPF
-RIP and OSPF only supports equal cost load balancing

Unequal Cost Load Balancing
-load balancing if metrics are not equal
-supported by EIGRP
-By using the
variance = Bandwidth successor/ Bandwidth slowest feasible successor
-EIGRP can implement unequal cost load balancing across 16 unequal cost load paths

Configuring Unequal Cost Load Balancing in EIGRP:
Variance = Bandwidth successor/ Bandwidth slowest feasible successor
Variance = 2.048 Mbps / 512 Mbps
Variance = 4
Note: By default, EIGRP supports equal cost load balancing with a max metric variance of 1. If the variance is greater than 1 then it is configured as unequal cost load balancing
Example:
R1#conf t
R1(config)# router eigrp 100
R1(config-router)#variance 4 – controls load balancing variance
R1(config-router)#end – exits to the privilege EXEC mode
R1#
Verify:
R1#Show IP route eigrp
R1#Show IP protocols
R1(config-router)#no variance 4 – disables the configured variance

Supernetting/Route Summarization/Route Aggregation:
172.16.16.0/24 – 172.16.31.0/24
1. Count the # of networks/IP addresses to be summarized.
# of IP address = 16
2. Nearest to or equal to the # of IP adress increment.
increment = 16
3. Get Summary range. Copy Classful network address and add increment to the octet where change in value happens. .16 – .31
172.16.0.0 – 172.16.15.255
172.16.16.0 – 172.16.31.255
172.16.32.0 – 172.16.47.255
4. Get lower and upper IP Limit (NSM)
count number of binary bits that did not change
lower 172.16.16.0 – 11111111.11111111.0001000.0
upper 172.16.31.0 – 11111111.11111111.0001111.0
_______________________________________________
11111111.11111111.11110000.0 = /20
5. Get summary address
lower limit/New Subnet Mask (NSM)

172.16.16.0/20

Configuring Summaries in EIGRP:
R1#conf t
R1(config)#interface serial 0
R1(config-if)#ip summary-address eigrp 100 192.168.10.0 255.255.254.0 – performs address summarization on 192.168.10.10/22
R1(config-if)#end – exits to privilege EXEC mode
R1#
verify using:
R1#show ip route eigrp

Routing Protocol Security
1. Passive Interface – interface whose network is advertised but is not sending out hello packets (hellos are disabled)
2. Authentication

Configuring Passive Interface in EIGRP
Best practice: All interface should be passive first
Example:
R1#conf t
R1(config)#router eigrp 100
R1(config-router)#passive-interface default – suppresses routing updates on all interfaces
R1(config-router)#end
R1#
verify using:
R1#show ip eigrp neighbors
R1#show ip protocols

Configuring EIGRP Authentication

Key Chain – hellokitty
Key-String [password] – bassstring

1. Create the key chain and the password inside keychain
R1#conf t
R1(config)#key chain hellokitty – sets the key chain to hellokitty
R1(config-keychain)#key 1 – key identifier
R1(config-keychain-key)#key-string bassstring – sets the key-string password to bassstring
R1(config-keychain-key)#end – exits to the privilege EXEC mode
R1#

2. Activate the authentication and configure key chain inside an interface
R1#conf t
R1(config)#interface serial 0
R1(config-if)#ip authentication mode eigrp 100 md5 – sets the authentication for eigrp to md5(keyed message digest)
R1(config-if)#ip authentication key-chain eigrp 100 hellokitty – sets the authentication key-chain to hellokitty
R1(config-if)#end – exits to privilege EXEC mode
R1#
verifiy using:
R1#show ip eigrp neighbors

Open Shortest Path First(OSPF) Protocols and Operations

OSPF Configuration:
CLI Commands:
R1#conf t
R1(config)# router ospf
R1(config-router)#network area

– OSPF advertises interfaces, not networks. Uses the wildcard mask to determine which interfaces to advertise.
R1(config-router)#end – exits to privilege EXEC mode
R1#
Example:
R1#conf t
R1(config)#router ospf 100
R1(config-router)#network 201.52.60.0 0.0.0.255 area 0 – Any interface with an address of 201.52.60.x is to be put into area 0
R1(config-router)#end
R1#
verify using:
R1#show ip route
R1#show ip protocols

OSPF Router-ID(RID)
1. Hard-Coded Router-ID
2. Highest loopback IP Address at the time of configuration
3. Highest IP Address of an “up up” physical interface at the time of configuration

Configuring OSPF Router-ID (RID)
R1 = 1.1.1.1 – set R1 RID to 1.1.1.1
Configuration Commands:
R1#conf t
R1(config)#router ospf 100
R1(config-router)#router-id 1.1.1.1 – sets the OSPF router-id to 1.1.1.1
R1(config-router)#end – exits to privilege EXEC mode
R1#clear ip ospf process – resets OSPF process

Configuring Routing Security:
1. Passive Interface
2. Authentication
Best Practice: We need to make all interface passive first
Configuration Commands:
R1#conf t
R1(config)#router ospf 100
R1(config-router)#passive-interface default – suppresses routing updates on all interfaces
R1(config-router)#end – exits to privilege EXEC mode
R1#
verify using:
R1#show ip ospf neighbor – shows OSPF neighbors

Note:All interface with routers connected should not be passive interfaces
Configuration commands:
R1#conf t
R1(config)#router ospf 100
R1(config-router)#no passive-interface – enables routing updated with interfaces that have routers that are connected
R1(config-router)#end
R1#
verify using:
R1#show IP ospf neighbor
R1#show IP protocols

OSPF Authentication:
Key-string [password] -> bassstring – use bassstring as key-string password

1. Inform the OSPF routing protocol to use authentication on all routers in area 0
Configuration Commands:
R1#conf t
R1(config)#router ospf 100
R1(config-router)#area 0 authentication message-digest – use message-digest authentication for area 0
R1(config-router)#end – exits to privilege EXEC mode
R1#

2. Configure authentication and password inside an interface
Configuration Commands:
R1#conf t
R1(config)# interface serial 0
R1(config-if)#ip ospf message-digest-key 1 md5 bassstring – sets the message digest authentication password key ID 1 to use md5 algorithm and use OSPF password bassstring
R1(config-if)#end
R1#
verify using: show ip ospf neighbor

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s