CCNA – Day 4

OSPF Metric: Cost

OSPF Metric Cost

Multi-Area OSPF Lab

Multi-Area OSPF

Configuration Commands:
R1:
conf t
router ospf 100
router-id 1.1.1.1
network 172.16.51.0 0.0.0.255 area 51
network 172.16.1.0 0.0.0.255 area 0
exit
VERIFY: #SHOW IP ROUTE OSPF

 

Route Redistribution

Route Redistribution – converting a route learned from one routing protocol to another
R1#conf t
R1(config)#router ospf 100
R1(config-router)#redistribute
R1(config-router)#end
R1#

IPv6 Address – 128 bit IP addressing scheme separated by network(first 64 bits) and host part(last 64 bits).
Steps for shortening the IPv6 address:
1. Replace Quartets of zeroes that are close together with ::. This can only be done once.
2001:0000:0000:0000:0012:0ABC:0000:AB00
2001::0012:0ABC:0000:AB00
2. Omit leading zeroes, and replace a quartet of whole zeroes with one zero.
2001::0012:0ABC:0000:AB00
2001::12:ABC:0:AB00

Determining the IPv6 Prefix from Address/Length
2000:1234:5678:9ABC:1234:5678:9ABC:1111/64
16 + 16 + 16 + 16 =64
2000:1234:5678:9ABC::/64 – network address/IPv6 Prefix
/64 – subnet mask/IPv6 length

Types of IPv6 Address and their first hex digits:
Address Type                     First Hex Digits
Global Unicast                    2 or 3(originally); all not otherwise reserved (today)
Unique Local                      FD
Multicast                            FF
Link-Local                          FE80

Global Unicast – Public IP Addresses
Unique Local – Private IP Addresses
Link Local – Automatically Generated IPv6 Address
FE80::<EUI-64 >, 64 bit Extended Unique Identifier (EUI-64)

Steps to getting the Link Local:

1. A 64-bit interface identifier is most commonly derived from its 48-bit MAC address. A MAC address 00:0C:29:0C:47:D5 is turned into a 64-bit EUI64 by inserting FF:FE in the middle: 00:0C:29:FF:FE:0C:47:D5.

2. Invert the 7th Significant Digit:

00:0C:29:FF:FE:0C:47:D5
0000 0000
0000 0010
020C:29FF:FE0C:47D5

3. Place FE80 in the beginning:
FE80::020C:29FF:FE0C:47D5

Subnetting using Link Local/Private Address
Unique Local IPv6 Address

CONFIGURING IPV6 INTERFACE ADDRESSES

R1:
enable
conf t
hostname R1
!
interface serial 1/0
ipv6 address 2001:10::2/64
no shut
exit

VERIFY: #SHOW IPV6 INT BRIEF

TO VIEW THE ROUTER MAC ADDRESS,

#show interface fa0/0

ca00.5a1c.0008
FE80::C800:5AFF:FE1C:8

R1:
conf t
interface loopback 0
ipv6 address 2001:30::/64 eui-64
no shut
exit

VERIFY: #SHOW IPV6 INTERFACE BRIEF

R1:
conf t
interface loopback 1
ipv6 address 2001:40::1/64
no shut
exit

VERIFY: #SHOW IPV6 INTERFACE BRIEF

R2:
conf t
interface serial 1/0
ipv6 address 2001:10::1/64
no shut
clock rate 128000
exit

VERIFY:#SHOW IPV6 INTERFACE BRIEF

FROM R2, PING R1
R2#ping 2001:10::2

R2:
conf t
interface serial 1/1
ipv6 address 2001:20::1/64
no shut
clock rate 128000
exit

VERIFY: #SHOW IPV6 INT BRIEF

R3:
enable
conf t
hostname R3
!
interface serial 1/1
ipv6 address 2001:20::2/64
no shut
exit

VERIFY:#SHOW IPV6 INT BRIEF

FROM R3, PING R2
R3#PING 2001:20::1

R3:
conf t
interface loopback 0
ipv6 address 2001:50::/64 eui-64
no shut
exit
interface loopback 1
ipv6 address 2001:60::1/64
no shut
exit

VERIFY: #SHOW IPV6 INT BRIEF

====================================
CONFIGURING OSPFv3 FOR IPV6

conf t
router ospf 100
router-id 1.1.1.1
network 10.0.0.0 0.0.0.255 area 0
exit

STEP1: WE ACTIVATE THE OSPF ROUTING PROTOCOL

conf t
ipv6 router ospf 100
router-id 1.1.1.1
exit

STEP2: WE ACTIVATE AN INTERFACE

conf t
interface serial 1/0
ipv6 ospf 100 area 0
exit

R1 = 1.1.1.1
R2 = 2.2.2.2
R3 = 3.3.3.3

R1:
conf t
! WE NEED TO TURN ON THE IPV6 ROUTING ! FUNCTION FIRST
!
ipv6 unicast-routing
!
ipv6 router ospf 100
router-id 1.1.1.1
exit
!
interface serial 1/0
ipv6 ospf 100 area 0
exit
interface loopback 0
ipv6 ospf 100 area 0
exit
interface loopback 1
ipv6 ospf 100 area 0
exit

VERIFY: #SHOW IPV6 PROTOCOLS

R2:
conf t
!
ipv6 unicast-routing
!
ipv6 router ospf 100
router-id 2.2.2.2
exit
interface serial 1/1
ipv6 ospf 100 area 0
exit
interface serial 1/0
ipv6 ospf 100 area 0
exit

VERIFY: #SHOW IPV6 PROTOCOLS

#SHOW IPV6 ROUTE OSPF

R3:
conf t
ipv6 unicast-routing
!
ipv6 router ospf 100
router-id 3.3.3.3
exit
!
interface serial 1/1
ipv6 ospf 100 area 0
exit
interface loopback 0
ipv6 ospf 100 area 0
exit
interface loopback 1
ipv6 ospf 100 area 0
exit

VERIFY: #SHOW IPV6 ROUTE OSPF

#SHOW IPV6 PROTOCOLS

==============================
PAKITANGGAL UNG OSPF SA R1 R2 AND R3

conf t
no ipv6 router ospf 100
exit

VERIFY: #SHOW IPV6 ROUTE OSPF (DPAT WALA NANG LAMAN)

————————————-
CONFIGURING EIGRP FOR IPV6

conf t
router eigrp 100
network 10.0.0.0
no auto-summary
exit

STEP1: WE ACTIVATE THE EIGRP ROUTING PROTOCOL

conf t
ipv6 router eigrp 100
router-id 1.1.1.1
no shut
exit

STEP2: ACTIVATE THE INTERFACE

conf t
interface serial 1/0
ipv6 eigrp 100
exit

R1 = 1.1.1.1
R2 = 2.2.2.2
R3 = 3.3.3.3

R1:
conf t
ipv6 router eigrp 100
router-id 1.1.1.1
no shut
exit
!
interface serial 1/0
ipv6 eigrp 100
exit
interface loopback 0
ipv6 eigrp 100
exit
interface loopback 1
ipv6 eigrp 100
exit

VERIFY: #SHOW IPV6 PROTOCOLS

R2:
conf t
ipv6 router eigrp 100
router-id 2.2.2.2
no shut
exit
!
interface serial 1/0
ipv6 eigrp 100
exit
interface serial 1/1
ipv6 eigrp 100
exit

VERIFY: SHOW IPV6 PROTOCOLS

#SHOW IPV6 ROUTE EIGRP

R3:
conf t
ipv6 router eigrp 100
router-id 3.3.3.3
no shut
exit
!
interface serial 1/1
ipv6 eigrp 100
exit
interface loopback 0
ipv6 eigrp 100
exit
interface loopback 1
ipv6 eigrp 100
exit

VERIFY: #SHOW IPV6 PROTOCOLS

#SHOW IPV6 ROUTE EIGRP

========================
PAKITANGGAL UNG EIGRP SA R1 R2 AND R3

conf t
no ipv6 router eigrp 100
exit

VERIFY: #SHOW IP ROUTE EIGRP (wala nang laman)

============================
IPV6 STATIC ROUTING

2 WAYS TO CONFIGURE
1. EXIT INTERFACE WAY
2. NEXT HOP IP ADDRESS WAY

conf t
ipv6 route /

R1:
conf t
ipv6 route 2001:20::/64 serial 1/0
ipv6 route 2001:50::/64 serial 1/0
ipv6 route 2001:60::/64 serial 1/0
exit

VERIFY:#SHOW IPV6 ROUTE STATIC

R2:
conf t
ipv6 route 2001:30::/64 serial 1/0
ipv6 route 2001:40::/64 serial 1/0
ipv6 route 2001:50::/64 serial 1/1
ipv6 route 2001:60::/64 serial 1/1
exit

VERIFY: #SHOW IPV6 ROUTE STATIC

R3:
conf t
ipv6 route 2001:10::/64 serial 1/1
ipv6 route 2001:30::/64 serial 1/1
ipv6 route 2001:40::/64 serial 1/1
exit

VERIFY: #SHOW IPV6 ROUTE STATIC

Access Control List (ACL)
2 Functions:
1. Classification
-Firewall, Security
2. Filtering
-Route Filtering

2 Types of Access Control List
1. Standard
-Very general rules
-uses source IP/Network address
2. Extended
-Very detailed rulings
-uses source IP/network address and source protocol
-uses destination IP/network address and destination port/application
2 Directions of Traffic
1. Incoming
2. Outgoing

Network Address Translation (NAT)
1. One Private IP to One Public IP NAT
2. One Private IP to Many Public IP NAT
3. Many Private IP to One Public IP NAT

or;
1. Static NAT – one to one address mapping. Manually configured.
2. Dynamic NAT – Many-to-many address mapping. Automatically assigned from pools of addresses
3. Overloading NAT with Port Address Translation (PAT) – Many-to-one address mapping

Virtual Private Network (VPN)
1. Intranet – A site-to-site VPN that connects all the computers at two sites of the same organization, usually using one VPN device at each site.
2. Extranet – A site-to-site VPN that connects all the computers at two sites of different but partnering organizations, usually using one VPN device at each site.
3. Remote Access – Connects individual Internet users to the enterprise network.

Configuring Routers to Support DHCP

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s